Can devices connect to loopback address of another device? - networking

Can devices connect to loopback address of another device? The loopback address can be assigned to any IP address e.g 12.12.12.12. It's not necessarily to be 127.0.0.1
Device supports multiple loopback addresses.

Other devices can connect to your loopback addresses as long as they have a route to them. For the special address range 127.0.0.0/8, but as you say you can configure other addresses as well. I usually use the dummy interface for this.
Distributing routes can be done manually by configuring manual static routes, or with routing protocols like OSPF and BGP. There are several implementations of those for most common operating systems.

A device can support multiple loopback interfaces (ex : Router/L3), but an interface support only one IP address .
A loopback interface could be connected to another device or not, it depends on your configuration ... you can manage the routes of all your network manually or you can use a routing protocol if Intra-domain then you use (OSPF or RIP) or Inter-domain than you use BGP.

Related

Separate LAN's using 2 Routers - Can ping devices on other LAN

so the setup I've got:
Main Router which receives the internet connection and is my primary WIFI network: 192.168.1.0/24
Secondary Router which I've connected via the following method to create a separate LAN: 10.3.3.0/24. Main Router's LAN port --> Secondary Router's WAN port.
I've got this setup fine and can get internet from the Secondary Router's LAN, no problem.
My question is: Is it normal behavior to be able to ping a device connected to the main router from the secondary router?
I would like to isolate devices on each LAN so that devices connected to the separate LAN's can't communicate and wondering if I'm able to achieve this using 2 consumer grade routers?
Cheers!
This is normal behavior because the secondary router knows that IPs in the 192.168.1.0/24 subnet should be forwarded to its WAN port, so it can access hosts connected to that network.
Sadly, you usually can't create 2 segregated subnets with 2 consumer-grade routers, as these only have 2 network interfaces (one for WAN and one for the built-in switch).
I also do not recommend doing this, as double NAT can have unexpected side effects. If you really want to separate devices on your local network, looking into VLANs is a better way. You can use your existing router but will need a compatible switch.
If your routers support vlan management you should use separate vlans for both subnets. Otherwise you cant devide your networks.

Configuration virtual Vlan instead of physical port

Currently i am studying for NAT and from what i read, vlans on physical port on switch actually not good for NAT.
I search for a couple of times but only sources that i got, configure the vlan on physical port like
interface gi0/1
switchport mode access
switchport access vlan 10
Instead of doing this, i want to do
interface vlan 10
ip add 10.1.12.254 255.255.254.0
ip nat inside
What is the differences between interface gi0/1 and accessing vlan through that port, and interface vlan 10?
I cannot make encapsulation dot1q through interface vlan 10, or it works only for physical ports?
Let's say that i have two vlans, vlan 10 (WLAN) and vlan 99 (USERS). Vlan 10 has an IP address 10.1.12.0/23 and port is gi1/0/24.
Vlan 99 has an IP address 10.1.14.0/24 and range is gi1/0/1-23.
Do I need to configure them like,
interface range gi1/0/1-23
switchport mode access
switchport access vlan 99
or are there any way for me to configure only interface vlan 99?
I know this is a basic configuration but two of them making me so confused.
Many thanks
One of the differences between interface VLAN and the physical interface is, you can add an IP address to an interface VLAN, but in L2 switch you can't add an IP address to a physical interface.
We can say physical interface is a layer 2 interface and doesn't support layer 3 options like IP and Routing and etc.
Network admins use Interface VLAN as a gateway for each VLAN. For example, if you want to use inter-VLAN routing, you can use interface VLAN as a gateway for all traffic in that VLAN.
when you say
int gig 0/0
switchport mode access
switchport access VLAN 2
The switch itself tags the port to dot1q vlan 2. So you don't need to tell the switch anything. You just need to put the physical port in the vlan.
VLAN tagging is an interface-level virtualization - it enables you to connect multiple L2 segments (broadcast domains) to a single physical interface (or an aggregated group), sharing the bandwidth.
On some devices that virtualization may have an impact on its other functions (like NAT), but generally that's not the case. Whether you use a routed/L3 port or a switched port with a switch virtual interface (SVI), a VLAN-to-IP binding, may be a matter of taste, architecture, policy, device capability or performance. On many devices, both approaches work absolutely fine.

What is an openstack port?

I am trying to map the notion of an openstack port to an IP abstraction. In the openstack documentation I see :
"A port is a connection point for attaching a single device, such as the NIC of a server, to a network. The port also describes the associated network configuration, such as the MAC and IP addresses to be used on that port."
So I assume a port must correspond to an IP interface (which in turn can map to a bridge, an ethernet interface or to one end of a veth link).
Is this a correct assumption? I am trying to figure out what IP abstraction maps to a loadbalancer port and I can't yet find it.
Thanks
Answering my own question (hopefully of help to others):
An openstack port corresponds to an ovs (or linnuxbridge) port that connects you up to a virtual network. A prefix of the port ID is used as a bridge name. You can create a port to a network and add it to a router.

2 routers and want windows to not use a network

Gonna use 'ROUTER ONE' and 'ROUTER TWO', for my examples.
I have two routers, one on wireless one on ethernet. Both have different names. I want windows to just use the internet connection on ROUTER ONE and not use the connection on ROUTER TWO, but I still want to access ROUTER TWO's IP. At the moment to use the network I have to unplug the cable, as I get on the site I want, then the OTHER router takes me too another network saying that the connection is unavailable.
So then, what do I do?
The router names are irrelevant, all that matters is their IP addresses. You can tell a computer which router to use by setting it gateway address to that router's internal IP address. You can do that in the DHCP settings if you want it applied network wide.
As far as accessing both routers it all depends on how your network is set up both physically and its IP scheme. If both routers are on the same physical network and IP scheme you should be able to access them. If they are on the same physical network but on different IP schemes you can assign a second IP address to a computer that is compatible with the second scheme so you will be able to access the second router.

What are the effects of incorrectly setting the netmask?

What are the effects of incorrectly setting the netmask? I have a C++ application that sets the network mask of a device. If the netmask is set incorrectly, tftp doesn't seem to work properly. Why would this happen? What other problems occur when the netmask is not properly set for a device/PC?
While this question is probably more about IP networks than programming it is a challenging subject for many developers.
The netmask delimits the host address (your PC or server) and the network address (the part of the logical network infrastructure in which your system lives). The two parts are used to deliver the data packet to the correct device. The network address is obtained by ANDing the netmask with the IP Address. Consider the following scenario:
IP Address: 10.0.1.1
Netmask: 255.255.0.0
The host address portion of the IP address for our PC is 1.1, so the PC knows that any host addresses starting 10.0. are local to it. Any addresses that then start 10.1, etc, are not 'local' and will need to be forwarded to a router. If you have another device intended to be on the same network that is:
IP Address: 10.0.2.1
Netmask: 255.255.255.0
Here the netmask is wrong for our example setup, this device is now going to see the network address as 10.0.2 and the host address as 1, if it tries to communicate with 10.0.1.1 it will see a network address of 10.0.1! Not local and so will refer it to the default router for forwarding. If the netmask was correctly set (i.e. the same as the first example, assuming that's the correct setting for your network) then the second device would see the first as local, i.e. on the 10.0 network and wouldn't attempt to forward the packet to a router.
Many protocols will happily cope with this but tftp is intended to operate within a single network and so will fail as there's a perception that the target is on a different network.
This may not describe your exact situation but I hope that the example demonstrates the important principle that configuration matters, you can't have an inaccurately configured environment and expect it to work.
The netmask determines which IP adresses are local (non-routed); IP adresses outside that range go through the router. If the netmask is wrong, the program tries to directly access sites where it has to go through the router, or vice versa.
The netmask defines, which part of the IP-address is used as address for the network and which part is used for the workstations.
First Example:
IP1: 192.168.20.4
IP2: 192.168.192.4
NM: 255.255.0.0
Both IPs are in the same net. They can communicate with each other without needing a router. That's because the IP-addresses will result in the same bitmask when you or it with the netmask.
Second Example:
IP1: 192.168.20.4
IP2: 192.168.192.4
NM: 255.255.128.0
Now both IPs are in different networks because when you or the IP-addresses with the Netmask, the resulting bitmask will be different and they wont be able to communicate with each other without a router that routes between the two networks.
You can test this by yourself with ipcalc.
Possible implications of mismatched netmask are explained here. In short:
The host is likely to construct routing table incorrectly.
The host will miss some broadcast packets and not send broadcasts properly.
Mis-function of TFTP is almost for sure caused by the first reason. It affects any other IP protocol in the same way.
Other answers mention only the first problem (which is OK, as the second one is rather marginal). Note that it is not the netmask of the interface itself which determines how the IP packets would be routed - it is the routing subsystem of the host; but the netmask is normally used for constructing the routing table.

Resources